Conos default sender email not working

When a user is sending out an email using cognos, it is always being sent using user’s email instead of default sender email.

add following setting on Cognos dispatchers

alwaysUseDefaultSender , set value to TRUE

You can use below article to get more detail steps:

How to set the default email sender to a specific value in Cognos Analytics 11.

https://www.ibm.com/support/pages/how-set-default-email-sender-specific-value-cognos-analytics-11

PH05363: WHEN A USER IS SENDING AN EMAIL OUT IT IS ALWAYS BEING SENT FROMTHE EMAIL ADDRESS SPECIFIED IN THE DEFAULT SENDER AREA.

https://www.ibm.com/support/pages/apar/PH05363

PH24943: DEFAULT EMAIL SENDER NOT SET WITH CA 11.1.6

https://www.ibm.com/support/pages/apar/PH24943

cognos content store not connecting to sql server

When trying to connect sql server database from cognos configuration content store getting following error:
[Content Manager database connection]
[ ERROR ] The database connection failed.
[ ERROR ] Content Manager is unable to connect to the content store. Verify that the database connection properties in the configuration tool are correct and that when you test the connection, the test is successful.

When you get this error:

First make sure you server can connect to SQL server by creating a ODBC connection and do a test. If successful then issue is with Cognos connecting to SQL Server.

Follow below steps:

Cognos Analytics connects to the content store via JDBC, not ODBC. These are completely different client interfaces so comparing ODBC to JDBC is not comparable.

It is important that you make sure that you are using the latest version of the SQL Server JDBC driver. It is recommended to use the 9.4 version of the JDBC driver as there are some changes with encryption defaults with the 10.2 JDBC driver that may break connections.

You can download the 9.4 driver here: https://go.microsoft.com/fwlink/?linkid=2183120

– Download the .zip file

– Extract the .zip file

– Copy the sqljdbc_9.4\enu\mssql-jdbc-9.4.1.jre8.jar file to your cognos_location\drivers folder

– Remove the old SQL Server JDBC driver so there are no conflicts

– Copy the sqljdbc_9.4\enu\auth\x86\mssql-jdbc_auth-9.4.1.x86.dll file to the cognos_location\bin folder. Remove any older sqljdbc_auth.dll file that was there previously

– Copy the sqljdbc_9.4\enu\auth\x64\mssql-jdbc_auth-9.4.1.x64.dll file to the cognos_location\bin64 location.

SQL Server 2016 uses TLS 1.2, so you will need to make sure that you configure Cognos to make a TLS 1.2 connection to your database. Please refer to the following TechNote:

https://www.ibm.com/support/pages/connection-sql-server-fails-when-server-configured-use-tls-12-or-connecting-sql-server-2016

Follow the steps under “To get the Content Store connection working”. Note: You will need to always launch the config using bin64\cogconfig.bat from this point onwards so it picks up the TLS 1.2 parameters.

Cognos Percentage calculation by total

percentage([Counts])
percentage(count (distinct [DataItem]))

Create a calculation by above syntax. Drag that column to cross-tab. You should be getting percentages of summary data.

Topics: Cognos Cross Tab & percent calculation in Total
cognos cross tab how to add percentage

https://it.toolbox.com/question/crosstab-percent-calculation-in-total-071706

cognos scheduled reports are stuck in wait state

in progress…

cognos notification test pass but email doesn’t come

Unable to send emails from Cognos Server but no errors appear in the cogserver.log file
https://www-01.ibm.com/support/docview.wss?uid=swg21339824

https://www.cognoise.com/index.php?topic=26364.0

https://it.toolbox.com/question/cnc-sds-0408-there-are-email-messages-waiting-to-be-sent-072011

CNC-SDS-0408 There are email messages waiting to be sent.

CNC-SDS-0410 The email message was not sent
https://www-01.ibm.com/support/docview.wss?uid=swg22012214

cognos analytics [Validate mail server properties.] [ ERROR ] The mail server cannot be reached.

Cognos Scheduled Jobs Randomly Stuck in ‘Waiting’ State
https://www-01.ibm.com/support/docview.wss?uid=swg21689979

Testing mail server connection: [ERROR] Mail server authentication failed
https://www-01.ibm.com/support/docview.wss?uid=swg21342280

cognos analytics RAVE visualization customize

ibm cognos rave visualization

Below links provide good information about rave visualization and customization.

Below articles provide good information about rave

https://www-01.ibm.com/support/docview.wss?uid=swg21973160

https://developer.ibm.com/recipes/tutorials/rave-charts-vs-external-charts-in-cognos/?mhq=rave&mhsrc=ibmsearch_d

Click to access HowtoaddextensiblevisualizationtoCognosActiveReports-AllVisualizations.pdf

cognos analytics heat map display numbers with total
https://www.ibm.com/developerworks/community/forums/html/topic?id=8205c888-235e-4922-b2a2-2b5964b61862&mhq=heatmap%20display%20values&mhsrc=ibmsearch_a

at following url you can find rave visualization customizer / sample visualzations and rave visualization customize –
https://www.ibm.com/developerworks/community/groups/service/html/communityview?communityUuid=9685c9a6-3133-4823-85e8-f5f81268267a#fullpageWidgetId=W561990aafebc_4d8b_9af8_7c03c0081265

https://www.ibm.com/communities/analytics/cognos-analytics-blog/cognos-business-intelligence-cognos-analytics-all-visualizations/

https://www.ibm.com/developerworks/community/groups/service/html/communityview?communityUuid=9685c9a6-3133-4823-85e8-f5f81268267a#fullpageWidgetId=Wc1aa99476ad4_4458_9a7d_4f3a60bc90f5

heatmap display values with totals:
https://www.ibm.com/developerworks/community/forums/html/topic?id=8205c888-235e-4922-b2a2-2b5964b61862&mhq=heatmap%20display%20values&mhsrc=ibmsearch_a

few useful links

https://www.cognoise.com/index.php?topic=22417.0

http://www-01.ibm.com/support/docview.wss?uid=swg21989490

https://www.ibm.com/support/knowledgecenter/en/SSEP7J_11.0.0/com.ibm.swg.ba.cognos.ug_cra.doc/t_asg_managing_visualizations.html

http://www-01.ibm.com/support/docview.wss?uid=swg21993750

https://www.ibm.com/communities/analytics/cognos-analytics-blog/cognos-business-intelligence-cognos-analytics-all-visualizations/

IBM Cognos analytics Product images don’t show in Event Studio

When trying to access Event studio , images/icons are missing. Errors show up when trying to accessing any icons.

Errors like below:

  • Object doesn’t support property or method ‘select Tab’ [getMessageFrame().selectTab(‘AgentTask-tasknumber’,’report’);]
  • ‘doAction’ is underfined[doAction(‘url’)]

 

Screenshot of Event Studio which is having missing images when accessed

event studio issue c11

Solution:

Mostly this issue is happening because of IIS configuration. To make sure this- open the dispatcher URL at server and check Event studio. Event studio should be working as  required. Now this tells us that there is some issue with IIS configuration.

Go through the event studio steps by following IIS configuration guide- Event studio section

https://www.ibm.com/support/knowledgecenter/en/SSEP7J_11.0.0/com.ibm.swg.ba.cognos.inst_cr_winux.doc/t_gateway_iis.html

Though you might have run the bat file given by IBM, It might still not do all of it correctly. Its better to double check.

When I had this issue. Event Studio  at URL Rewrite was missing 1 condition and Logical processing was set to “Match All”. I added that missing condition and changed Logical processing to “Match Any”

 

Following article talks about similar issue at UNIX server

https://www-01.ibm.com/support/docview.wss?uid=swg22010297