IBM Cognos analytics Product images don’t show in Event Studio

When trying to access Event studio , images/icons are missing. Errors show up when trying to accessing any icons.

Errors like below:

  • Object doesn’t support property or method ‘select Tab’ [getMessageFrame().selectTab(‘AgentTask-tasknumber’,’report’);]
  • ‘doAction’ is underfined[doAction(‘url’)]

 

Screenshot of Event Studio which is having missing images when accessed

event studio issue c11

Solution:

Mostly this issue is happening because of IIS configuration. To make sure this- open the dispatcher URL at server and check Event studio. Event studio should be working as  required. Now this tells us that there is some issue with IIS configuration.

Go through the event studio steps by following IIS configuration guide- Event studio section

https://www.ibm.com/support/knowledgecenter/en/SSEP7J_11.0.0/com.ibm.swg.ba.cognos.inst_cr_winux.doc/t_gateway_iis.html

Though you might have run the bat file given by IBM, It might still not do all of it correctly. Its better to double check.

When I had this issue. Event Studio  at URL Rewrite was missing 1 condition and Logical processing was set to “Match All”. I added that missing condition and changed Logical processing to “Match Any”

 

Following article talks about similar issue at UNIX server

https://www-01.ibm.com/support/docview.wss?uid=swg22010297

 

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s